Jump to content

Поддержка каких версий Delphi должна быть в FGX Native?


Поддержка каких версий Delphi должна быть в FGX Native?   

22 members have voted

  1. 1. Поддержка каких старых версий Delphi должна быть в FGX Native?

    • Delphi 10.3
      2
    • Delphi 10.4
      22


Recommended Posts

  • Administrators

Здравствуйте.

В свете выхода новой версии Delphi 11 и бесплатной версии Delphi 10.4 Community Edition, мы хотели бы узнать ваше мнение о том, какие версии Delphi должны поддерживаться библиотекой FGX Native.

Delphi 10.3 не поддерживает в полной мере разработку под iOS, так как немаловажные изменения происходят на уровне самой IDE, где мы не можем вносить правки (к примеру сборка iOS Static Launchboard Splash Screen). Помимо этого, поддержка дизайнера библиотеки под 10.3 привносит определенные трудности, так как часть современных компонентов, к сожалению, недоступны в 10.3. Исходя из вышесказанного, поддержка 10.3 с каждым релизом увеличивает время разработки и тормозит перенос библиотеки FGX Native на новые версии Delphi

Выход версии 10.4 Community Edition может быть хорошим поводом для того, чтобы отказаться от поддержки 10.3 и сфокусироваться на развитии библиотеки и скорейшей реализации поддержки Delphi 11, вместо поддержки старой версии Delphi.

Просьба всех принять участие в голосовании. Ваше мнение важно для нас.

Link to comment
Share on other sites

В принципе я ЗА отказ от 10.3.

Мне 10.3 нужна только для сборки под андроид 5. В фирме есть много планшетов на андроид 5 на которые нет официальных обновлений, а админы против кастомов. С другой стороны приложение уже закончено и в него вносятся только мелкие правки и я могу создать себе отдельную виртуалку с зафиксированной библиотекой fgx.

Link to comment
Share on other sites

Я за поддержку только Delphi 11.

P.S. в голосовалке нет возможности проголосовать против всех старых версий

Edited by tumaso
  • Like 1
Link to comment
Share on other sites

1 час назад, tumaso сказал:

Я за поддержку только Delphi 11.

P.S. в голосовалке нет возможности проголосовать против всех старых версий

Вы уверены, что готовы лишиться рынка 50% пользователей Android?

 

Edited by Dmitry Sh.
Link to comment
Share on other sites

7 часов назад, Dmitry Sh. сказал:

Вы уверены, что готовы лишиться рынка 50% пользователей Android?

 

Я совсем не готов, потому буду изучать возможности компиляции под более ранние версии андроид.

Link to comment
Share on other sites

19 часов назад, Dmitry Sh. сказал:

Вы уверены, что готовы лишиться рынка 50% пользователей Android?

 

Отвечу как еврей, вопросом на вопрос: а что для вас приоритетнее, поддержка старых телефонов или более стабильная работа приложения на новых телефонах?

Link to comment
Share on other sites

44 минуты назад, tumaso сказал:

Отвечу как еврей, вопросом на вопрос: а что для вас приоритетнее, поддержка старых телефонов или более стабильная работа приложения на новых телефонах?

спросили - отвечаю.

Раз Вам не важны ваши клиенты, то посмотрите на проблему с другой стороны.

FGX - это бизнес. Ярославу и Виктору нужны клиенты.
Разработчиков использующих Delphi не много, а купивших 11 версию еще меньше.
Community позволяет эту клиентскую базу увеличить, а как следствие увеличить стимул к развитию продукта.

Хорошего дня 🙂

  • Like 1
Link to comment
Share on other sites

  • Administrators

Моя позиция такова. Я считаю, что распределение пользователей по уменьшению количества таковых это:

  1. Большая часть клиентов - это пользователи Community Edition
  2. Пользователи с наличием полноценной лицензии: подписка / корпоративная лицензия.

Поэтому на основании этого предположения переход с 10.3 Community Edition на 10.4 Community Edition должен выглядеть для большинства хорошим решением: новая среда, новые возможности, отказ от ARC и тд.

Но поскольку есть еще и вторая группа пользователей. то собственно по этому здесь и появился этот вопрос. Потому что у всех разные ситуации, и кому-то важна поддержка 10.3. Как мы выяснили из этого вопроса, она важна из-за поддержки Андроид 5.0.

К сожалению поддержка Android 5.0 в 10.4 и 11.0 зависит уже не от нас. Так как зависимость подняты на уровне RTL, системы сборки и тд.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...