Jump to content

Delphi 11.2 не совместима с 11.1 / Delphi 11.2 is not compatible with 11.2


Yaroslav Brovin
 Share

Важна ли для вас поддержка RAD Studio 11.1, в то время как появилась 11.2?  

9 members have voted

  1. 1. Важна ли для вас поддержка RAD Studio 11.1, в то время как появилась 11.2?

    • Мне важна поддержка RAD Studio 11.1
    • Я готов обновиться до RAD Studio 11.2
    • Мне важно иметь поддержку обеих версий RAD Studio 11.1 или 11.2
  2. 2. Is it important for you to support RAD Studio 11.1, while 11.2 appeared?

    • It's important to support RAD Studio 11.1
    • I'm ready to update to RAD Studio 11.2
    • It's important to support RAD Studio 11.1 and 11.2

This poll is closed to new votes


Recommended Posts

  • Administrators

Недавно компания Embarcadero выпустила обновление RAD Studio 11.2. Однако, часть пакетов IDE в данной версии не совместима с 11.1. Это означает, что пакеты дизайнера собранные на 11.1 не работают в 11.2 и наоборот. 

В частности версия библиотеки 1.14.4.0 работает в 11.1, но не работает в 11.2. А обновление 1.14.4.1 работает в 11.2, но не работает в 11.1. По сколько любая библиотека для Delphi собирается под мажорную версию студии 11.*, поскольку гарантируется полная совместимость пакетов между минорными версиями.

Отсюда возникает главная проблема. На текущий момент у нас нет возможности быстро и оперативно собирать библиотеку под 11.1 и под 11.2 отдельно. У нас есть несколько путей решения текущей проблемы:

  1. Отбросить поддержку 11.1 и требовать установку 11.2. Но установка 11.2 может быть проблематичной из-за отсутствия активной подписки.
  2. Собирать отдельно версию библиотеки для 11.1 и 11.2, включать обе версии в инсталятор и дать пользователю возможность выбрать требуемую версию. 

Просьба отписаться в комментариях к данному вопросу и проголосовать. 


Embarcadero recently released the RAD Studio 11.2 update. However, some of the IDE packages in this version are not compatible with 11.1. This means that the designer packages built on 11.1 do not work in 11.2 and vice versa.

In particular, the library version 1.14.4.0 works in 11.1, but does not work in 11.2. And the update 1.14.4.1 works in 11.2, but does not work in 11.1. By how much any library for Delphi is built for the major version of studio 11.*, since full compatibility of packages between minor versions is guaranteed.

Hence the main problem arises. At the moment, we do not have the ability to quickly and efficiently build a library under 11.1 and under 11.2 separately. We have several ways to solve the current problem:

  1. Drop support for 11.1 and require the installation of 11.2. But the installation of 11.2 may be problematic due to the lack of an active subscription.
  2. To build a separate version of the library for 11.1 and 11.2, include both versions in the installer and give the user the opportunity to choose the required version.

Please left your comments to this question and vote.

Link to comment
Share on other sites

1 час назад, dervish00 сказал:

а я сейчас на 10.4 Community Edition ((( Что делать?

проблема только с 11.Х. Как я понимаю проблему, на одной машине не живут вместе 11.1 и 11.2, поэтому проблемы со сборкой дистрибутива.

с версией 10.4 вопросов нет, она как работала так и будет.

Link to comment
Share on other sites

  • Administrators
1 час назад, dervish00 сказал:

а я сейчас на 10.4 Community Edition ((( Что делать?

Ничего. Поддержка 10.4 остается. Речь идет только о 11.1 и 11.2.

32 минуты назад, Dmitry Sh. сказал:

проблема только с 11.Х. Как я понимаю проблему, на одной машине не живут вместе 11.1 и 11.2, поэтому проблемы со сборкой дистрибутива.

Да, так и есть. Обычно Embarcadero выпускает хотфикс для устранения подобных проблем.

Link to comment
Share on other sites

  • Administrators

Всем поучаствовавшим спасибо за обратную связь. Скоро выйдет новый релиз 1.14.5.0, где при установке надо будет выбрать ваше версию 11.0-11.1 или 11.2. Так что Мы добавили поддержку и 11.2 и старых версий 11.0 - 11.1.

  • Like 3
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...